This object is in archive! 

Vdj xml import error

djpari89 shared this question 8 months ago
Answered

i get this error when trying to import my vdj db:

Type Error: Cannot read property 'getAttribute' of undefined


Specs; windows 10 64 bit,the xml file is around 16 mb in size

things i have tried...run mixo as admin and win 8 compatibility mode.

make sure the xml file has the permissions to be accessed...

made a copy of the same xml and tried a different browsed location

Comments (3)

photo
1

We are aware of issues importing VDJ xml files and are working towards a fix.


I've subscribed you to the idea so you'll be notified as soon as there is an update:

https://support.mixo.dj/t/failed-vdj-tracklist-import

photo
1

This has now been fixed in our latest release:

0.12.0

Download the latest version in App or via https://beta.mixo.dj.

photo
1

even with this 0.12 version i get the attached error

photo
1

Thanks for the screenshot, I have reopened the idea for this and we will continue to look into the issue

https://support.mixo.dj/t/error-when-importing-virtualdj-8-xml-file

photo
1

Could you please send us you're database.xml file for VirtualDJ, thanks!

photo
1

i have attached a google drive link for my more than 16 mb size xml file below...i am still getting the error on 0.13 version...i must note that my music files are nested in another partition and hence vdj creates a database folder in the root of that partition..and my filepaths in the xml file will start with "M:" instead of "C:".

Also..mixo is installed on the C drive...and the music and the attached xml file are nested in the M drive..hope this helps in detecting the bug.

https://drive.google.com/file/d/1slw6kRLnBgoAdBsKKfYYsirmllOAe7fm/view?usp=sharing

photo
1

Thanks for sending this through, really helpful. We'll have a look through and compare to see what would be causing the issue.


I can see that from the file you're using VDJ version 8.1, I believe the latest update is 8.4, are you able to update?

You can download the latest version here:

http://www.virtualdj.com/download/index.html

This may be the cause of the issue, but we'll look into it further in the meantime.

photo
1

thanks for your reply and this is an update on my situation....i found a way for vdj to re create my xml file and the newly created xml does show version 8.4(which is also the program version im using)....and this xml does not produce the error....

having said that...i think it should still be labelled as a bug as some users may not be able to 'reconvert' their xml version to the compatible 8.4.

photo
1

Thanks for confirming this!

Absolutely, in fixing the issue it will allow support of earlier 8.# versions, provided there aren't specific issues with older VDJ database versions - but I don't think there are.

photo