tags bug

djpari89 shared this question 5 months ago
Solved

is anyone else getting a problem of the some files not being tagged properly only when importing form vdj xml...specifically that the artist & title tag are not being separated...for eg,

Katy Perry - Firework is being stored as the title and there is no artist,instead of Katy Perry in artist and Firework in the title field.

i have made sure that the tags are correct in vdj itself to rule out that...so i have reset mixo...and i loaded a same track that had the problem...but through the import track way instead...and it is correct..so it's probably a bug with the import vdj way...i say probably because im currently re-importing my entire db(which will take a while)..so i will report after if the bug persists...

as im on the topic....if there is a bug...would i have to reanalyze my entire db again??? i see there is a "Re-analyze Track(s)" feature...will that do the job if i batch select?

Comments (3)

photo
1

We're not able to replicate this, please can you send:


- Your database file so we're able to compare the two.

- Screenshots of the issues you're seeing

- Operating System & device info

- Confirm you meet our minimum requirements:

https://support.mixo.dj/guide/mixo-system-requirements

- Check you're running our latest MIXO version:

https://www.mixo.dj/release-notes


The Re-analyse option will scan all the tracks selected for changes to the track tags and update them in MIXO.

photo
1

ok it seems that in a haste i didn't allow mixo to properly analyze my database...im in the process of doing so now....it is very time consuming...but if it a one off analysis that's fine...which arises the question...how will mixo deal with changes in my database? for eg,deleting,moving,copying tracks,changing tags and subsequent filenames...note all this internally with vdj to avoid db errors...as i want to avoid reanalyzing my entire db over and over.

i hope there will be some algorithm to only check for changed files or attributes and update changed rather than a total reanalyze.

also an option to clean database will be good,or a folder called missing files or something with the option to remove missing tracks or relocate them....

photo
1

You'll only need to analyse any tracks that you import into MIXO and can re-analyse ones that you've made changes to in another program.


We are looking at an automatic sync feature in later releases to update your database:

https://support.mixo.dj/t/auto-sync

But we'd suggest using MIXO as your library management and then exporting playlists/folders to VirtualDJ as needed. This avoids having to re-import the database if any major file changes are made.

We are also looking at missing file warnings and a relocate feature:

https://support.mixo.dj/t/missing-file-marker

https://support.mixo.dj/t/relocate-missing-files

I've subscribed you to all of the above ideas to keep you updated.

photo
1

ok i have finally finished analyzing my entire db...and the tag problems persist..i have attached screenshot and my xml file...note that some of the files in that specific folder are tagged correctly but majority have the tag problem.

Two things that i have noticed...the cues sometime take a while to load onto the waveform...and that might give some users a hint that they did not analyze properly...i suggest that there is some buffer time until you actually see the tracks and able to play them so that the cues and all other info can load properly...the other is that there seems to be cover art size limit causing some tracks not too load..i have singled out these tracks and resized their cover art and the have successfully been added...i simply reloaded the xml file and it just analyzed those tracks and not the entire db..which is how it should work..that's great!

i do not know if there is some specification about covert art limits in the manual etc...if not,this should be added somewhere

photo
1

upon further examination..i have realized some cover arts are not being loaded...u have a copy of my xml file so u can check..for reference...there is no cover art loaded in mixo for the file "Cascada - Ready For Love"...and coincidentally this track has the tag error also!

photo
1

Thanks for sending that through and for making a note of what you did to fix / replicate the issue that's a huge help!

There shouldn't be an artwork file-size limit - but it is cropped to be 300px wide on import.


Looking through the XML I noticed the following which is possibly causing the problem:

1. The tracks missing the artist name or other tags simply don't have these attributes, for example 'Author' is the Artist. Check in VDJ that these tracks have a tag for this with a value and try re-analysing the database / check consistencies and that may fix the XML file. You probably need to close VDJ for it to save these updates.


2. For the cover art tags, these have the attribute 'Cover' and the ones with the missing art seem to have a value of either '1' or '2' whereas ones that have art have a much larger number - again, re-analysing in VDJ should update this in the database.


In regards to the cues taking a while to load - there's going to be a big UI/UX update soon, so if there's anything on our roadmap along side this, feel free to upvote, it helps us determine what people are using the most.

Let me know if this helps at all!

photo
1

i am not sure of what u mean...my tags are correct...i am using the track "(Viking)Ding Dong - Stay In Yuh Lane(Genna Bounce Riddim)" for this demonstration..i have attached screenshots from the windows browser,vdj's tag editor and mp3 tag of the same file and all are correct...ps i saw u wrote something about "Author" being the artist...i cannot reproduce this on my end.

photo
1

Right concerning the covert art missing now...this is a weird discovery....for the same file that i used in the demo.. "Cascada - Ready for Love" ...the covert art displays for within vdj tag editor..but not in mp3 tag....i do not know if it because of the format of the picture used...i have checked the file permissions etc and nothing wrong there....so i decided to change the cover art inside vdj....and it still doesnt reflect in mp3 tag...so i changed it directly in mp3 tag and reloaded the xml in mixo and to my surprise..there is still no cover art loaded...so at this stage i do not know what is causing the problem..hopefully you guys can sort it out

photo
1

Just to check, are you adding these tags in the windows browser or within the VDJ tag editor?

If it's the former, could you try importing that track having edited the tags in VDJ.

If it's the latter, please attach one of the problem tracks and I'll investigate further.

photo
1

if u edit tags in vdj..they are saved automatically with an option 'setTagsauto' on....if u change tags outside vdj(not filenames)...you can simply batch select and there is a reload tags option....i do almost all my mods in tags in vdj...and if i use mp3 tag i simply reload tags as in the above...

i am sending you my version of "Cascada - Ready For Love"...the thing is..it seems u will import the track using the import tracks feature in mixo...while i have done it the vdj xml way....i would try it the "Tracks" way to troubleshoot,but i do not want to mess up the xml way...note the track i am sending has both problems of cover art and artist ok.

photo
1

Thanks for confirming and sending that through.

I've just done some testing and both through tracks and the xml file it imported correctly. As you can see in the XML view it contains the 'author' attribute whereas in your file it did not. I've also added a screenshot of it in MIXO.


Could you make sure that you update MIXO to the latest version v0.15.0, you can do this in app or download here. Also update VDJ as well and try again.

Hopefully this should fix the issue, but let me know.

photo
1

Ok just a bit of an update...I noticed what u were pointing out with the tag author attributes being missing...so I installed the latest build of vdj and reloaded all tags,a few times...one time was not enough...and it seems that all the songs in my xml file now have the missing tag author section....thinking It was a mixo problem...I resetted mixo and am now in the process of reloading my entire db(I hope i never have to do this again)...which brings me to a question...what files do I have to save in another location to essentially backup MIXO'S offline database so incase I just want to test another version of my db..I can manually backup some files...I see there is the cache folder...is that where the info is stored?

On the issue of the covers...I did see that some numbers were huge and some were like 1 or 2 as u pointed out...so before I reloaded the entire db..I selected a song with 1 as the value of the cover and loaded it into mixo..and the cover loaded fine...so with my entire db...I can only say when it is completed...judging from the last time...this would be In about 12 hours from now...will keep u posted.

photo
1

I completely understand and we really appreciate you continuing to test, it's incredibly helpful.

What version of MIXO are you currently on? Please make sure it's updated too, we were having problems with VDJ in earlier versions so it's very important that it is version v0.15.

We don't currently have the database backup yet but it is something we will be adding in the beta, we agree it's hugely important, not just for this use case but in general.

I've subscribed you to the idea so that you'll get an update when it's been added

https://support.mixo.dj/t/1847-main-database-backup-and-compare

photo
1

It's now at 66% analysis at the moment..but I did happen to go over to the tracks although it was still analyzing..and checked a file that I saw completed in the queue and everything was correct...but as I say I can't give a proper report until is completely finished...

Some of my tracks.. I have not added cover art as yet..and obviously I will add new tracks in the future...when I do add covers to these tracks or add new tracks through vdj...will simply re adding the new xml to mixo and analyzing update the new cover tags and new added tracks?? Or will it go over the same day long process???

Btw...I always use the most updated version as I know you guys are constantly throwing out fixes...did everything with 0.15

photo
1

Well that's good news so far and thanks for using the latest version that is always important.

Right now, it would be a full reimport - however the goal is to have a quicker process by auto-syncing to various softwares like VDJ.

https://support.mixo.dj/t/auto-sync

I've added you to this one too, so you'll be kept updated.

photo
1

UPDATE

the process has finished and everything seems ok..i have noticed a few things...if i add a few tracks to my collection via vdj and then reload the updated xml into mixo..the tracks are added with the obvious duplicate popup...

if i update an existing track's tags(actually added a missing cover art)...the changes DO NOT reflect in mixo(i think u indicated that this is not yet possible)...having said that....if i delete the track,then reload the xml,then the changes reflect as the track is freshly reimported...i hope this info is useful in making the "bridge" between softwares even better....the planned auto-sync feature should take of this because users will hope that the import should be a one time process.

photo
1

Thanks djpari!

Absolutely, everything you've mentioned there is current expected behaviour, and as you said, when the auto-sync feature is available this will take care of the need to reimport the entire database when making updates to your tracks in your chosen DJ software.

photo
photo
1

No problem..keep up the good work!