Failed Imports - Traktor .nml import

adam shared this question 31 days ago
Answered

So I finally got around to my first tests of the desktop app this morning.

When I import my Traktor "collection.nml" file I get a "Failed Imports" dialogue box with "The tracks below were not imported due being too large, corrupt or missing". It then lists all my tracks.

So not a single track has imported. All my playlists appear but they are all empty.

My set-up:

MacBook Pro running macOS 10.15.4

Traktor 3 Pro (3.3.0.108)

MIXO 0.9.0


My music and Traktor collection are on an external drive. I have 1614 tracks in the collection. Traktor sees all my tracks as does Apple's Music app.

I have reset MIXO and clerked it's cache and tried again. Still no joy.


Any ideas?

Comments (10)

photo
2

Hi Adam, thanks for sending in all your details. This is a bug we know about around importing large NML files:

https://support.mixo.dj/t/large-nml-import

I've subscribed you to the idea so you'll receive updates - currently it's in our planned section on our roadmap


https://support.mixo.dj/roadmap

photo
1

Hi Jon


Thanks for getting back to me. Good to know it’s a bug and not something I’ve done.


I’ll setup a smaller library on another machine for testing.

photo
1

No worries! As we're in beta, we're all about bug smashing so anything you run into just let us know, we really appreciate it!

photo
1

Hi Adam, how did the smaller library work out, did you get any errors?

photo
1

Hey Jon

So I set up a new test system.


My set-up:

MacBook Pro running macOS 10.13.6

Traktor 3 Pro (3.3.0.108)

MIXO 0.9.0


With a clean Traktor library I then added 5 tracks. Analysed them and starred one track. All tracks are AIFF files and all on the same drive as Traktor and MIXO.


Quit Traktor and attempted to import the .nml file into MIXO. First attempt hung after Parsing was completed. It recognised that there were 5 tracks but Import remain with a waiting status. Eventually I quit MIXO. Opened Traktor again to check the files were all there and playable, they were. Check that the path in preferences to my collection file was the default one I'd tried to load in MIXO, it was.

So back to MIXO and attempted to import the same .nml file. This time it was successful tho it took ages to Analyse, sitting it 0% for a goof few minutes.

Once done all the tracks are in MIXO. Now I need to test the sync with Dropbox and the App.

photo
1

Just to add to the above. I'm using a pretty old MacBook Air (13-inch, Mid 2012) with a 1.8GHz Core i5 and 8GB or RAM for testing. It seem that when MIXO is running the kernel_task in Activity Monitor shoots up in CPU usage and the machine become very sluggish. I also the the MIXO Helper (Renderer) like to hog a lot of RAM. Was well over 1.7GB at one point.

photo
1

Thanks for sending that all through Adam!

I'm glad you were able to get the smaller library to work, but it shouldn't take that long for only 5 tracks. We are aware of some performance issues and optimising this is one of our top priorities, whether it's a large or small library.


We've also had others mention that MacBook Airs from the same time period are hanging when importing tracks:

https://support.mixo.dj/t/macbook-air-not-importing-tracks

I've subscribed you to this idea so you'll get updates and I've updated the notes to include this thread.

To help us even further, could you follow this guide to turn on logs

https://support.mixo.dj/guide/how-to-turn-on-logs

Then, try importing the library again and go to: Music > MIXO > Logs - and send us the files there.

Thanks so much for being thorough Adam, this is exactly the kind of feedback we're after!

photo
1

I have enabled logs. Only realized after my tests that it’s not on by default.


Will retest later today.


DropBox sync worked but I have no idea where on my DropBox it’s uploaded too. Will have a look later.

photo
1

Update.

So I reset MIXO and reimported the same .nml file which still only has 5 tracks.

Loads and parses the file fine and then there is a delay before analysing. Seems to vary. First time was around a minute. Reset the app again and tried again. This time it was around a 20sec delay.


Syncing between the iOS app and the desktop all seems to work well. Was able to update tags and playlists in the app and those were carried over to the desktop when it synced. When I reset the app and reimported the .nml the changes I had made in the app were overwritten. This was as I expected as the sync will always follow the most recent changes and as the .nml import was more recent they become the master.

It might be worth having an options to return to previous sync??

Have a question about the DropBox structure but I'll do that in a separate post.

photo
1

Thanks for this Adam!

The process of importing / analysing is something we are working to improve and make as fast as we can, so we really appreciate this feedback and the logs.

I'm glad the syncing is working for you across devices as it should be, and I've raised an idea about sync backups / selecting latest version between devices

https://support.mixo.dj/t/backup-sync

photo