Rekordbox 7 Cues not exporting from Mixo to Serato

Scott shared this question 37 days ago
Answered

Just signed up for Mixo Gold and am trying to replicate my Rekordbox 7 library in Serato as I have a few friends that use it.


I successfully imported everything into Mixo and I can see the cue points and loops are all in there when I click on the songs.


When I export to Serato (and select to update ID3 tags) all goes smoothly and the crates all move across to Serato, but the cue points do not. I forced Serato to re-analyze everything but nothing changes. Am I missing a step here?


Thanks

Best Answer
photo

I'm pleased to announce MIXO v1.66 is now live with a fix for cues getting added to track tags, instead of overwriting them.

https://www.mixo.dj/versions?v1.66

Thanks for the feedback!


Remko
MIXO team

Replies (5)

photo
1

Hi Scott,


It sounds like you did everything right. You have to make sure the toggle is turned on when you export to Serato, or just use the stand alone Update ID3 Tags export option.


My recommendation is to quit Serato and MIXO, then open MIXO and try again with a small playlist. Open Serato and play one of the tracks to see if the cues are there.


Also check the file formats are supported.

https://support.mixo.dj/guide/write-to-track-id3-tags


Remko
MIXO team

photo
1

I've tried both exporting ID3 tags only and also closing/opening and just exporting one playlist to Serato but unfortunately neither has seemed to work (Serato doesn't find any files to analyze which I assume means none of the ID3 tags have changed).

How do I check that Mixo is updating ID3 tags in the right files? My mp3s sit in the Music folder, but there is a sub-folder in there where Serato crates etc sit.

Or could it be a limitation of Serato Lite?

Thanks again

photo
1

That's strange. Ok one way to check if the cues have been written to the track is like this:

1. Duplicate one of your tracks and move it to your desktop or somewhere easy to find.

2. Create a Test playlist in MIXO and drag this track into it.

3. Once the track is analysed, right-click and view Track Info.

Any cue points imported from the track's tags during analysis should now show in the track info.

Let me know the result. Also, if the cues do show, please send me the track and I'll try it in my Serato!

Remko

MIXO team

photo
1

Hi Scott,

I've just tested v1.65 on Mac and Windows and everything is working correctly. However, I noticed that the cues are not overwritten but in fact added to, so the result is lots of the same cues.

This could be the issue you're experiencing. Either way, we'll get this fixed for the next release.


4fc5bc64f7ba8b0db1fe4d0de7737f2c


Remko
MIXO team

photo
1

I'm pleased to announce MIXO v1.66 is now live with a fix for cues getting added to track tags, instead of overwriting them.

https://www.mixo.dj/versions?v1.66

Thanks for the feedback!


Remko
MIXO team

photo
1

Thanks, I'll give this a test when I have some time

photo
1

I have just tested this now and I think the issue is maybe coming from writing cues in Mixo to ID3 tags.

I tried copying one of my mp3s (which already had a cue point and a loop saved in Mixo) to my desktop, setting up a new test playlist in Mixo and dragging the file in but the cues are all empty.

photo
1

Strange, everything seems fine to me.

Here's a demo video re-analysing in MIXO after adding cues + showing how Serato also sees the new cues:

https://take.ms/xhpAA

Let me know if this helps. If it's still not working, you could send me your track via email and I'll check it myself.


Remko
MIXO team

photo
1

I manually added some cue points in Mixo to the copied file, exported the test playlist to Serato and these cue points are now showing up after analysis.

But still none of the cues on the files imported into Mixo from rekordbox are exporting across correctly. Note that Serato wasn't showing any cue points from cue #5 onward so if they've been written in the tags at any point after cue #4 then that's maybe why they aren't showing up. Should I clear my library in Mixo and try re-importing from rekordbox and then try exporting again?

photo
1

You should be able to just Update ID3 Tags in the latest version to fix the cues.


Try one playlist at a time initially.


If you've re-analysed tracks in MIXO then the Rekordbox cues will have been replaced. In which case Reset MIXO and try again.


Remko
MIXO team

photo
1

I tried:

1) Debug > Reset Mixo

2) Cleared my Serato library

3) Import rekordbox library into Mixo, cues are showing up fine like before

4) Export > ID3 tags and picked a single playlist (I'm not selecting 'Save Mixo tags to Comments' but should I be?)

5) Dragged two of the files from my library in windows explorer into Serato. It automatically analyses when importing it but still no cues are showing up

I'm on version 1.66.2. Am I missing a step somewhere in here? It feels like ID3 tags aren't being updated because if I re-analyse any song in Mixo and select 'replace cues' then the cues actually disappear.

photo
1

You should be able to drag the track straight from MIXO into Serato, to make sure you definitely have the right file.

Otherwise, please send me one of your tracks to test with to team@mixo.dj.

Thanks!

Remko
MIXO team

photo
photo
1

Hi Scott,


I think I've found and fixed some issues with updating ID3 tags.


If the track has a BPM value with a decimal place it was failing silently. There was another issue that was rare but is also fixed.


I'll let you know when these fixes are live so you can test again.


Remko
MIXO team

photo
1

MIXO v1.67.0 is now live with some fixes for Update ID3 Tags:

https://www.mixo.dj/versions?v1.67.0

Remko
MIXO team

photo
1

After updating, I tried:

1) Reset Mixo

2) Import from rekordbox, cues and loops have come in successfully

3) Export ID3 tags

4) Took a separate test copy of an mp3 file and imported it back into Mixo and there are no ID3 tags on the file so it's still not working.


To further test I did the following:

1) Manually added cue points 1, 2, 3 and 6 in Mixo.

2) Exported ID3 tags

3) Imported to Serato. Cue points 1, 2 and 3 showed up (I use serato lite which only displays up to 4 cues)


Looks like ID3 tag updates are still only working if the changes are made in Mixo. Anything imported from Rekordbox doesn't work.

photo
1

Oh interesting! One thing to try (if you're not already) is to import via the Rekordbox XML, rather than direct using the Rekordbox 6 import.


If that still doesn't work, please send me your XML and I'll relocate a track to one of my own and see if I can replicate.


However, if it does work let me know!


Thanks!


Remko
MIXO team

photo
1

Just tried importing via rekordbox xml but unfortunately the process went exactly the same. I emailed you my xml file if that helps.

Thanks

photo
Leave a Comment
 
Attach a file