Missing cue points after exporting a Traktor playlist to Rekordbox

Stefan shared this question 2 months ago
Solved

Hi there,

I've just run into an issue while testing moving track infos from Traktor to Rekordbox over Mixo. This is how I proceeded:

1. Ive imported my Traktor collection to Mixo

2. Ive exported Rekordbox.xml to Mixo default export path with only a traktor playlist containing 2 songs

3. Ive updated the path to recordbox.xml in Rekordbox. After that I could open it in the sidebar and see the 2 songs from my Traktor playlist. All good so far.

But after importing the songs to my RB collection, I noticed that

- the cue points are not displayed in the order configured in Traktor. For example, I set the 1st cue point as entry and the 2nd as exit point so it is always at the end. So after exporting to rekordbox.xml, I expect these cue mappings: 1 => A, 2 => B, and so on.

- an additional cue point for "AutoGrid/BeatMarker" has been added to my hot cues. Meaning that if I have 8 cue points in my track, the last one will not be considered by RB. I just saw that Traktor automatically creates those points when the beatgrid is set during analysis. However despite these additional points, Traktor maps the cue points to the correct values so Mixo should also be able to I guess? Actually the issue in Mixo is that it considers and saves these metadata as cue points (you can see that in the UI) and forward them to RB as such.

Isnt there another way to pass the beatgrid information to RB than in the node "POSITION_MARK" of the rekorbox.xml? Do you think it is possible to fix this import/export issue soon?

My set-up:

Win 10 64 Bit

Traktor 3 Pro (3.2.0.60)

MIXO 0.9.0

Rekordbox 5.6.0


Thanks in advance!

Best Answer
photo

This has now been fixed in our latest release:

v0.15

Download the latest version in App or via https://beta.mixo.dj.

Comments (6)

photo
1

Thanks for testing and sending through all the details, it really helps.

I have created an idea for this and subscribed you to it so you'll receive updates


https://support.mixo.dj/t/traktor-mixo-rekordbox

Do you see the cuepoints correctly for the tracks in MIXO?

When the cuepoints are reordered in RB, are they all shifted up by one, or is it random?


I can't say when there'll be a fix for this, but we review our roadmap everyday so please know that feedback like this is extremely valuable, thank you!

photo
1

Hi Jon,

thanks for your quick feedback and for adding this bug to your backlog. It would be great to have it fixed otherwise this issue will make things harder for me considering that I have a big library, dont have much time and that I will still have to jump from Traktor to RB and vice versa at least untill end of 2020.

To get back to the issue, no I dont see the cue points correctly in Mixo either and the problem is as I previously said that Mixo interprets these beatgrid informations wrongly.

- The cue points are all shifted by one in Mixo. RB then gets the same order as in Mixo.

- the shifting causes my 2nd cue point to be ignored (if 8 cue points are set in Traktor) or to be set at cue point 6 (if 5 cue points are set in Traktor).


Ive attached some screenshots to illustrate the issue with a track that comes with 5 cue points from Traktor. Hope that helps.


Regards

Stefan

photo
1

No worries, and thanks for sending through the screenshots.

On Monday, I will have a developer come back with more information on how we are handling beatgrids / cuepoints.

photo
1

We are looking at changing how MIXO reads the cue points so they display in the order they were created:

https://support.mixo.dj/t/cue-point-order


I've created ideas to ignore the AutoGrid marker if it's not stored as a hotcue and for the cue point shifting:

https://support.mixo.dj/t/ignore-autogrid-marker-from-traktor

https://support.mixo.dj/t/cue-shift


The cue shifting is likely due to the compression of mp3 files and how they are read by different software, have you got some uncompressed music files you can test to see if that stops the issue for you?

photo
1

Hi Miles,

sorry for the late answer, I havent been on here for a while.

Thanks for the new tickets created regarding this issue, that's great news! Regarding your question, no I dont have uncompressed music files but I will try to convert one file and test when I get some free time. However I dont think that switching to uncompressed files would be an option since they take lot more space and dont save tag-informations? So I gess I would just need to adjust the cue positions if needed :)

photo
1

No worries at all!


In regards to the AutoGrid appearing as a hotcue, we are still working on this and we're expecting this to be fixed in a near-future update.

The Cue Point Order issue is now fixed as of v0.14.0, update in-app or download again here

photo
1

Thx for the feedback! I will retest asap.

photo
photo
1

This has now been fixed in our latest release:

v0.15

Download the latest version in App or via https://beta.mixo.dj.