Album artwork lost if app closed during sync upload

Miles shared this idea 6 months ago
Completed

If app is quit while still uploading tracks to cloud storage the album artwork will be missing for all tracks when the app is reopened

Comments (3)

photo
1

Hey Miles,

I experienced this as well - is there any way to have the tracks appear with the album artwork after this has happened?

I don't mind doing a fresh install/reanalyzing and uploading etc. Thanks!

photo
1

I've created an idea to manually refresh the album artwork:

https://support.mixo.dj/t/refresh-album-artwork

The artwork being lost on quit was fixed a few versions ago, are you still experiencing this?

Make sure your app is up to date and if you do get missing artwork, try View > Reload

photo
1

App is up to date, and I've tried the View > Reload without any changes unfortunately. I didn't have logging enabled but have set it on for the future.


I had tried removing and readding tracks and they still remained without artwork.

Is there a way to reanalyze tracks? And also reupload them?


Thanks for your support Miles appreciate it very much.

photo
1

It will take a little bit of time for the artwork to show as tracks are analysed after import.


I've added that to the roadmap:

https://support.mixo.dj/t/re-analyse-tracks

Tracks will upload whenever you import them and aren't removed from your cloud storage unless you delete them from the library.


If you want to re-upload them you'd just need to import them again.


Are you not seeing artwork for any of your imported tracks? Can you send us your system information?

photo
1

I was able to just reset my account and reupload and artwork is displaying, thanks Miles. I think I had deleted from my library when tracks were still in the analysis queue and this messed things up.


I'm not sure if I should open an additional thread or if this is specific to this task I just did, but I have only about 200 tracks synced (uploaded) to the cloud, but am unable to play them on another device like my phone. I am getting a Track Not Found error, even though the tracks, artwork, metadata, playlists are all showing on the android app. Let me know if I should open an another topic- thanks Miles!

photo
photo
1

To add to the previous comment, my tracks are present in dropbox as well

photo
1

Great to hear you got your artwork showing.


With the missing tracks that could be to do with you resetting the user if you still had tracks in the cloud.


Please can you try the following:

1. Reset your user

2. Delete the MIXO folder from your cloud storage

3. Restart the app on your computer and phone (make sure to quit the app fully on your phone)


4. Re-import your tracks again and wait for them to upload


If you still get the error on your phone after that let me know.

photo
1

Hey Miles, I am still receiving the error after doing full reset on the phone and then computer and closing both of them out

Tracks are visible on Mixo on my android, including waveform etc but telling me track isn't found

photo
1

Thanks for testing.


I've created an idea and subscribed you:

https://support.mixo.dj/t/track-not-found-on-android

Do you have a Google Drive account you can use for sync instead?

photo
1

I do have a Google Drive account and waiting for the login insecure device issue to be resolved :) Will let you know when I'm able to log in after this fix is out this upcoming week

photo