Downloaded Songs on iOS Not Playing or Taking a Long Time to Play

Brian shared this question 9 days ago
Answered

I have downloaded songs to my iPhone and when I click on them to start playing, it buffers and doesn't start playing.

Here is some additional info:

  • Using an iPhone with iOS version 17.5.1
  • All songs imported from Serato
  • Connected to Dropbox cloud storage
  • All songs that I am trying to play on my iPhone have been downloaded and have pink dots next to them

Why is it taking so long (ie, the songs are buffering and not playing) and in most cases, why aren't the downloaded songs not playing at all?

Replies (5)

photo
1

Hi Brian,


To verify if your tracks are actually downloaded you can check the iOS Files app where you should find them in playlist folders.


If they are there, go back to MIXO and try playing a track from a different playlist. This will clear the cache and rebuild the queue which normally fixes any issues related to caching.


Remko
MIXO team

photo
1

I verified that the tracks are in my iOS folder and I tried to play a track from another playlist but unfortunately the buffering persists.


Any suggestions on next steps?

photo
1

What file types are they? Perhaps they're not supported.

https://support.mixo.dj/guide/what-file-types-does-mixo-support


Remko
MIXO team

photo
1

The file types are a mixture of MP3, WAV, AIFF, M4P, and MP4 which seems to be supported based on the link that was provided.


Any other suggestions?

photo
photo
1

By the way, I can play the files with no issues from the iOS files folder for the MIXO folder. They open up right away with no issues. I attached a couple of screenshots for reference.

photo
1

Looks like you downloaded a huge playlist with over 4,494 tracks... how many tracks are in that playlist?


Remko
MIXO team

photo
1

4494.


It does the same thing with a 31 song playlist too.

photo
1

If you turn off the download toggle for a small playlist, wait for the pink dots to disappear, then turn it on again to re-download the tracks, do those tracks work?

Please also try logout and login, just in case that miraculously works!


Remko
MIXO team

photo
photo
1

To confirm, does the toggle need to be turned off on the desktop app or my phone?

photo
1

Downloading tracks on the desktop app will not affect the mobile app.


If you want to download tracks from your cloud storage to your iOS device you simply turn the toggle on at the top of the playlist.


So far I haven't been able to replicate this issue so I'm quite confused!


Remko
MIXO team

photo
1

I kinda figured that the desktop app would not be affected, but given the issues so far, I wanted to confirm. I toggled the download button on the 31-song playlist and 4 of the songs no longer show a pink dot. There are 27 songs that still show a pink dot. Is there a way to speak to someone about this? It may help in understanding and recreating the issue. Please let me know. Thanks!

photo
photo
1

By the way, the buffering still persists. I have logged out and did a restart on the app but once I open it back up and log back in, the buffering is still there and the pink dots are still there as well. I have attached a screenshot for you to review. If I’ve missed something on the toggle please let me know. Thanks!

photo
2

Ok I see that playlist is not downloaded but some of the tracks are, probably because they exist in another downloaded playlist.


If you tap the download icon for that playlist and wait for the other tracks to download, do they work? For example, the top track Every Little Step.


Remko
MIXO team

photo
1

I clicked download and the tracks showed pink dots. However, when I tried to play “Every Little Step” nothing happened. It buffers and doesn’t play. I included a screenshot.


Thoughts?

photo
1

I've tested with AIFF, MP4, M4A, MP3 and WAV by downloading the playlist and playing the tracks whilst on flight mode.

Everything works!


The only thought I have is that perhaps M4P tracks don't decode in MIXO, but I don't have any of these to test.


Can you verify this theory but checking if the tracks you have are M4P?


Remko
MIXO team

photo
1

Most of the files are MP3. Here is the text info from the Serato Crate that shows the same:


  1. Bobby Brown - Every Little Step (12" Version) Intro) Radio).mp3
  2. Ralph Tresvant-Sensitivity..mp3
  3. Hold On (HH Clean Intro).mp3 Hold On (HH Clean Short).mp3
  4. If It Isn't Love.mp3
  5. 07 After 7 - Can't Stop (Nonay 504 Edit).mp3
  6. Can't Stop (Clean).mp3
  7. Soul for Real - Every Little Thing I Do.mp3
  8. That's The Way Love Goes.mp3
  9. That's The Way Love Goes (CJ R&B Mix) (HH Clean Intro).mp3
  10. Real Love.mp3
  11. Real Love (HH Clean Intro).mp3
  12. Real Love (Hip Hop Mix) (HH Clean Intro).mp3
  13. Real Love (Hip Hop Mix) (HH Clean Short).mp3
  14. Next - Too Close (Intro Clean).mp3
  15. Next - Too Close (Clean).mp3
  16. Mark Morrison - Return Of The Mack (HH Clean Intro).mp3
  17. Don't Walk Away (Clean).mp3
  18. Don't Walk Away (HH Clean Intro).mp3
  19. Don't Walk Away (HH Clean Short).mp3
  20. I Like.mp3
  21. I Like (HH Clean Intro).mp3
  22. Rump Shaker (Clean).mp3
  23. Rump Shaker (HH Clean Intro).mp3
  24. Rump Shaker (HH Clean Short).mp3
  25. Teddy's Jam.mp3
  26. The Way You Love Me (HH Clean Intro).mp3
  27. Is It Good To You (HH Clean Short).mp3
  28. Do Me.mp3
  29. Is It Good To You.mp3
  30. Is It Good To You (HH Clean Intro).mp3

I realize that it's only 30 files, but the info (ie, 1 file is missing from the copy and paste), but the main call out is that the files are MP3's.

Any other suggestions?

photo
1

*** I realize that it's only 30 files, but the info is shows that the files are primarily MP3s (ie, 1 file is missing from the copy and paste).

Any other suggestions?

photo
1

Baffling. Did this happen after you re-imported and synced perhaps?


Remko
MIXO team

photo
1

Unfortunately due to the restrictive nature of production builds on mobile we have very little way of debugging this.


At the moment I'm just working through different theories as to why this is happening for you but not in any of our tests.


Remko
MIXO team

photo
1

Yes. Should I remove all of the downloaded files from phone and start again?

photo
1

At this stage I'm not sure since your smaller playlist with 31 tracks still didn't work.


Have you installed the latest version, 1.65?


Remko
MIXO team

photo
1

I deleted the app from my phone and started from scratch. I downloaded the latest version and only downloaded the 30-song playlist. So far, so good. The songs are playing right away with no issues. I have a master folder with 4000 songs that I use to create DJ sets.

Can MIXO handle a 4000-song playlist for download to my phone?

photo
1

Ok that's good but I'm still left wondering why nothing was working.


Which version did you have when you downloaded the tracks in the first instance?


Also, please make sure the tracks were removed from the Files app when you deleted MIXO. If they still exist you might find that they will get reused, this the process will be much faster but I'm not sure. I'll have to test all of this!


When downloading that many tracks to a mobile device there are a lot of things to consider: storage, bandwidth, network issues, your phone going to sleep etc.


There's plenty of things that could cause unusual behaviour that I need to try to replicate!


Remko
MIXO team

photo
1

Sorry but I don’t remember the version that I used earlier. I just started using it a week ago so it’s probably the version prior to the latest one.


I made sure to delete all tracks in the iOS files folder before reinstalling.


By the way, should I be seeing waveforms when the songs are playing? I don’t see any in the 30 songs in my playlist.

photo
1

Ok no worries.

The waveforms are created during analysis on desktop and uploaded to your cloud storage. If you did not analyse on desktop or the waveforms failed to upload, you won't see them on mobile.


Remko
MIXO team

photo
1

Ok. Thanks.

photo
1

I don't know if the analysis actually happened. I opened the desktop app and went to import. I selected my playlist but didn't see the analysis progress bar pop up. I thought that it may have happened quickly in the background so I went to my phone to see if the waveforms were there and they were not. I included a screenshot from my desktop.

Did I miss a step?

photo
1

You could check your cloud storage to see if the Waveforms folder has files.

To re-upload waveforms, select the tracks, right-click and select "Upload Tracks". This will attempt to upload the track and waveform again, unless they already exist.


Remko
MIXO team

photo
Leave a Comment
 
Attach a file