Second device not downloading tracks

Tristan C shared this question 11 months ago
Solved

My laptop does not seem te be in sync with my library on my desktop.

I currently have my desktop Mixo instance setup to be the primary device with Google Drive connected. It seems like the music files have been uploaded correctly to the cloud because I can browse them on the Google Drive web interface.

On my laptop, I have done a clean install of Mixo (including deletion of the AppData and the ~/Music/MIXO folder) and toggled the "Download All Music (Other Computer)" option. After doing this, Mixo supposedly starts downloading all my files, but after it is done only a very small part of the tracks can be played on the Mixo client and the ~/Music/MIXO/Music folder is way smaller than it should be. If I open ~/Music/MIXO/Logs/2023-08-13-cloud-error there are a bunch of the following error: "2023-08-13T16:40:40.555Z,Local 'dbxRefreshToken' is missing" Not sure if it has anything to do with my issues.

Best Answer
photo

Good to hear! I completely forgot to follow up with this thread, but deleting the Google Drive folder resolved the issue for me

Replies (2)

photo
1

Hi Tristan,


Please try reloading or restarting MIXO. All downloaded tracks should have a pink dot.


Let me know if this resolves your issue.


Remko

photo
1

I have done that multiple times. It keeps getting stuck like this on overy track except for 1/10 of the tracks.

photo
1

Hi Tristan,

Just following up on this to let you know MIXO v1.37 is now live with a fix for tracks re-downloading on other devices, after re-importing on your primary device.

There is also a fix for a hang that was caused by errors during downloading of tracks, with some improvements for hangs caused by bad folder names on Windows.

Please do let me know your feedback!

Remko

photo
1

Good to hear! I completely forgot to follow up with this thread, but deleting the Google Drive folder resolved the issue for me

photo
1

Ah that's good to know! I'll mark that as the solution then.

Thanks!

photo
photo
1

Hi Tristan,

Have you tried disconnecting and reconnecting your Google Drive on your other device?

Remko

Leave a Comment
 
Attach a file