After latest update on iOS, waveforms not showing

Lazer Mike shared this question 9 months ago
Solved

I updated to the latest version on iOS and now I can’t see waveforms or memory points, see attached screenshot

Replies (8)

photo
1

Hi there,

Please make sure you are on v1.9.

You could try Reset Local (Settings/Debug), then login and wait for sync to complete. Cue points are downloaded last so if you play a track before sync has finished you wouldn't see them.

The waveform downloads when you play a track and saves it for the next time. If you see the slider it means you don't have a waveform for that track or it failed to download for some reason. You can always close the player and open it again to force a recheck.

Let me know if any of this helps.

Remko

photo
1

Hi Remko,

Thank you for your answer.

I tried Reset Local in Desktop where I imported the tracks, and in iOS, and it still doesn't show waveforms on tracks in iOS. Is it possible that when importing it failed to import waveforms somehow? I could try to reset MIXO and import it all again, but it's an extensive library and it would take some time. I will try to import a few tracks in a test playlist to check it and will get back to you.

Regards,

Carlos
Lazer Mike

photo
1

Hi again,

I just tried importing 2 tracks and it showed correcly. When I Imported my library, I did it in several chunks of 300+ tracks, is it possible that when uploading lots of tracks at the same time, it fails with the waveforms?

photo
1

It's possible that some waveforms failed to upload due to an error or drop in internet at the time.

Are there many tracks without waveforms?

One way to fix missing waveforms is to select all the tracks in one playlist, for example, then right-click and choose "Upload Tracks". If the track has a waveform locally but not in the cloud, it will get uploaded. Existing tracks that were already uploaded will get skipped, so the whole process could be very fast.

Give that a go and let me know if it helps.

Remko

photo
1

Sorry for the late response.

I ended up resetting MIXO and re-uploading everything. It took a while but it's done.

I noticed 2 things though:
- In the iOS app, I can see memory points on a list at the end of the Info page of each track, but I can't see them in the waveform, or in the "+" buttons. In the desktop top version there is a dropdown to toggle between Cues and Memories, I mainly use Memories, so is there a way to see / add / edit them in the iOS app?
- I went through some waveforms to check if all was ok, (in the desktop app), and found out that some grids were off, not according to the Rekordbox grid. When I import tracks from Rekordbox, does MIXO analyze and creates a grid of its own, or keeps the Rekordbox one? I attached a screenshot to better understand what I mean.

Thanks again for your support.

Cheers,

Carlos
Lazer Mike

photo
1

Hi Carlos,

Ah yes, the waveform only shows hotcues, not memory cues but the track info shows everything.

As for beatgrids - MIXO will use available tempo tags in the XML (RB5) or db (RB6) to offset the start of the grid but any further adjustments are not often available during import. However, you can manually adjust them in MIXO.

Beatgrid compatibility is typically limited between different DJ software, because every system is totally different. Whilst we have some data, not all data is always available, so the beatgrids may look slightly different in some cases. This can be easily fixed in MIXO and once you've adjusted the grid it will save for next time.

We are looking into the best option of toggling the cue types on the Player page on mobile. It will probably an Advanced Setting, so I'll let you know when this gets added.

Remko

photo
1

Thanks for your answer, Remko!
Cheers,

Carlos
Lazer Mike

photo
2

No problem!


Let me know if you need any further support at any stage.


Remko

photo
photo
1

Hi Carlos,

I'm pleased to announce MIXO v1.11 is now live with a new option to switch the cues in the mobile Player to memory cues.

You can turn this on via Settings/Advanced.

Thanks for the feedback!

Remko

photo
1

Hi Remko,

Just seen this new feature, perfect!
Thanks for the update!

Regards,

Carlos
Lazer Mike

photo
Leave a Comment
 
Attach a file