Why does MIXO only support Android 10+?

Since November 2020 all Android Apps can only support Android 10 or higher as per Google's policy.

This is part of Google's approach to upgrade users to the latest operating system.

For more information on system requirements for MIXO, please see:

https://support.mixo.dj/guide/mixo-system-requirements

For more general information on Google's policy regarding this, please see:

https://developer.android.com/distribute/best-practices/develop/target-sdk

Is this article helpful?
0 0 0